Emails are not sent

Write about issues that you have found.

Moderators: Koduc, Xpycm

Forum rules
Pay attention! Forum is not a means for guaranteed support of clients and users. An answer as well as a quick answer is not supposed on the forum. We post messages as soon as possible.

The message limit on the forum is 3 messages per day.
If you want to say "thank you" then use the function "Give good reputation point", which is a green icon "plus" under the nickname of the person, who answered the message.

Emails are not sent

Postby Xpycm » 04 Dec 2013, 11:07

a.To fix an error, we need to see the full text of the error. So you should paste the following code:
Code: Select all
$mailer->SMTPDebug true;
$mailer->Send();
echo 
$mailer->ErrorInfo;
exit;  

after $mailer->IsHTML(false);
in the /protected/modules/notifier/components/Notifier.php file.

b.If you get the error 503, saying that the message is not sent, follow the instruction below:
The possible causes of your problem and their solutions:

1) the emails are not sent because of incorrect smtp settings in the admin area of your site if you use smtp for sending emails. So, please, correct the settings:
Settings - > section Email - > edit the lines correctly;

2) the emails are not sent because one or more actions are disabled in the admin area of your site;
Settings - > section Notifier - > activate the necessary lines:
a) Should the system send a letter to the user after he/she has filled the registration form?
b) Should the system send a letter to the administrator when new user has been registered?

3) the emails are not sent if your hosting provider has some unusual settings for sending emails. And so please contact your hosting provider.

c.And you can also set the sending of emails here:

Open protected\modules\notifier\components\Notifier.php file
And add the smtp settings which you have got from your hosting provider into the code itself (so the CMS will use the smtp settings from the code, not from the dashboard)

For example:
Code: Select all
$mailer->Host 'Address of SMTP server';
$mailer->Port 'Port of SMTP server';
$mailer->Username 'SMTP user login';
$mailer->Password 'SMTP user password';   


If the data which you have got from your hosting provider do not work again, you can use the smtp data of Microsoft.which always work.
So you should paste the following code:
Code: Select all
$mailer->SMTPSecure 'tls';
$mailer->Host "smtp.live.com";
$mailer->Port 587;
$mailer->Username "outlook.com login";
$mailer->Password "outlook.com password";  


instead of the existing lines.:
Code: Select all
$mailer->Host param('mailSMTPHost''localhost');
$mailer->Port param('mailSMTPPort'25);

$mailer->Username param('mailSMTPLogin');  // SMTP login
$mailer->Password param('mailSMTPPass'); // SMTP password 
Dropbox
Open Real Estate CMS: FAQ | FAQ 2 | FAQ 3
Image
Xpycm
Web Developer
Web Developer
 
Posts: 261
Joined: 30 Dec 2011, 11:06
Reputation point: 2

Re: Emails are not sent

Postby danny » 02 May 2014, 03:49

) the emails are not sent because of incorrect smtp settings in the admin area of your site if you use smtp for sending emails. So, please, correct the settings:

question: Your setting below imply on My domain control panel or OPE setting if OPE where is the setting section?
Settings - > section Email - > edit the lines correctly;

2) the emails are not sent because one or more actions are disabled in the admin area of your site;
Settings - > section Notifier - > activate the necessary lines:
a) Should the system send a letter to the user after he/she has filled the registration form?
b) Should the system send a letter to the administrator when new user has been registered?

3) the emails are not sent if your hosting provider has some unusual settings for sending emails. And so please contact your hosting provider.

c.And you can also set the sending of emails here: DONE

Open protected\modules\notifier\components\Notifier.php file
And add the smtp settings which you have got from your hosting provider into the code itself (so the CMS will use the smtp settings from the code, not from the dashboard)
I HAVE DONE THIS PART - STILL RECEIVE ERROR 503 WHEN LISTING
danny
Stranger
 
Posts: 4
Joined: 02 May 2014, 03:38
Reputation point: 0

Re: Emails are not sent

Postby andipas » 02 May 2014, 08:43

ERROR 503 - This bug is related to the settings on your server.
andipas
Web Developer
Web Developer
 
Posts: 115
Joined: 28 Dec 2011, 22:37
Reputation point: 1

Re: Emails are not sent

Postby danny » 10 May 2014, 07:20

Hello,
I manage to receive the listing Property email as admin but not the user , which mean the user didn't receive the notification, Could it be the setting on my user SMTP user login, and the user password?
There is the error quote after submission the listing form:
You must provide at least one recipient email address
And with message:
you are successfully registered. To activate your account, please click the link in the activation email which has been sent sent to .....@...com
.
The user didn't not receive any activation email..

I have created a user login (user@mydomain.com) and password (udud3... )in the email setting is this the culprit?.
danny
Stranger
 
Posts: 4
Joined: 02 May 2014, 03:38
Reputation point: 0

Re: Emails are not sent

Postby fisher » 12 May 2014, 09:35

It can be fixed in admin panel
fisher
Citizen
Citizen
 
Posts: 63
Joined: 15 Apr 2013, 09:30
Reputation point: 1

Re: Emails are not sent

Postby superness » 22 May 2014, 03:27

how can you fix this in the admin panel?

I am also receiving the error message:

Error 503
The message is not sent ErrorInfo: You must provide at least one recipient email address.

I already made the correct smtp set up in the email. but i am still receiving the error. I also tried changing the codes in the notifier but still has the error.

can someone please help me to solve this issue?

this error message is being received when a new user clicked the list your property and she is not a registered user yet.

but if a new user clicks the register button first, the user and admin receives a notification email. so i know that the smtp details i entered are correct.

thanks.
superness
Stranger
 
Posts: 1
Joined: 22 May 2014, 03:21
Reputation point: 0

Re: Emails are not sent

Postby Koduc » 26 May 2014, 07:38

superness wrote:Error 503
The message is not sent ErrorInfo: You must provide at least one recipient email address.

Provide me with FTP access to your site (you can send it via private messages here). I will try to find and fix this issue.
-- Меньше знаешь - крепче спишь --
User avatar
Koduc
Team lead
Team lead
 
Posts: 64
Joined: 28 Dec 2011, 09:11
Reputation point: 0


Return to Issues

Who is online

Users browsing this forum: No registered users and 4 guests

cron